2.4.1.1 Class Activity – Tutor me! Answers

2.4.1.1 Class Activity – Tutor me! Answers

Class Activity – Tutor me! (Answers Version – Optional Class Activity)

Answers Note: Red font color or gray highlights indicate text that appears in the Answers copy only. Optional activities are designed to enhance understanding and/or to provide additional practice.

Objectives

Configure initial settings on a network device using the Cisco IOS software.

Background / Scenario

(Students will work in pairs. Packet Tracer is required to be used with this activity.)

Assume that a new colleague has asked you for an orientation to the Cisco IOS CLI. This colleague has never worked with Cisco devices before.

You explain the basic CLI commands and structure, because you want your colleague to understand that the CLI is a simple, yet powerful, command language that can be easily understood and navigated.

Use Packet Tracer and one of the activities available in this chapter as a simple network model. Focus on these areas:

  • While the commands are technical, do they resemble any statements from plain English?
  • How is the set of commands organized into subgroups or modes? How does an administrator know which mode he or she is currently using?
  • What are the individual commands to configure the basic settings of a Cisco device? How would you explain this command in laymen’s terms? Use parallels to real life whenever appropriate.

Suggest how to group different commands together according to their modes so that a minimum number of moves between modes will be needed.

Answers Note: This optional Modeling Activity may be used as a graded assignment. However, its purpose is to help students reflect on the knowledge acquired from Chapter 2, focusing on how the Cisco IOS is used directly to configure intermediary devices. Answers facilitation of the discussion should encourage student-to-student discussions of each other’s work.

Required Resources

  • Packet Tracer
  • Any simple network model activity available from Chapter 2

Reflection

  1. After completing Chapter 2, do you feel as though you have a concrete understanding of what the Cisco IOS does and how it operates? What were some of the difficulties you encountered when explaining the basic CLI commands and structure to your colleague? If you were the “new colleague,” what would be some of the difficulties that you would have learning the basic CLI commands and structure?
    _____________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________
  2. Answer the following questions, and discuss your answers with the entire class:
    1. While the commands are technical, do they resemble any statements from plain English?
      ________________________________________________________________________________________________________________________________________________________________________
    2. How is the set of commands organized into subgroups or modes? How does an administrator know which mode he or she is currently using?
      ________________________________________________________________________________________________________________________________________________________________________
    3. What are the individual commands to configure the basic settings of a Cisco device? How would you explain this command in laymen’s terms? Use parallels to real life whenever appropriate.
      ________________________________________________________________________________________________________________________________________________________________________
    4. With the help of your colleague, try to suggest how to group different commands together according to their modes so that a minimum number of moves between modes will be needed.
      ____________________________________________________________________________________
      ____________________________________________________________________________________

(Answers will vary (represented below are Chapter 2 content-based variations):

  1. While the commands are technical, do they resemble any statements from plain English?
    Absolutely. Keywords like enable, password, banner, address, shutdown are ordinary words whose meaning in CLI is appropriately adapted but still carrying a strong relevancy to their common usage.
  2. How is the set of commands organized into subgroups, or modes? How does an administrator know which mode is he/she using currently?
    First, the level of access to CLI can either be a user (user EXEC) level, or an administrator level (privileged EXEC). From the administrator level, the configuration mode can be accessed that is internally divided into global configuration mode, line configuration mode, interface configuration mode and other modes as necessary. The administrator is informed about the current mode in the prompt where the > symbol represents user access level, # represents administrator access level, and optional keywords in parentheses designate the configuration mode and possible submodes.
  3. What are the individual commands to access and configure the basic settings of a Cisco device? How would you explain these commands in layman terms? Use parallels to real life whenever appropriate.
    enable – become empowered to complete control over a device
    configure terminal – Start the configuration editor, accepting changes from the terminal
    hostname – Assign a name to a device
    service password-encryption – Causes the device to obscure all entered passwords in the configuration so that they cannot be eavesdropped
    line con 0 – Enter the configuration of the line, or the “socket”, labeled with CONSOLE 0 on the device and used to manage the device
    line vty 0 4 – Enter the configuration of 5 virtual “sockets” that allow managing the device remotely, through the network
    password – Set up a password to be used when accessing the device
    login – Protect the access using a login procedure requiring a password defined used the password command
    exit – Leave the current mode and exit to the higher placed mode.
    enable secret – The secret phrase which protects the usage of the enable command
    banner – The message displayed to a user that tries to access the device
    interface Vlan 1 – enter the configuration mode of the interface called Vlan1
    description – Assign a textual comment to an interface to help the administrator know what is the purpose and location of the interface
    ip address – Assign a numerical IP address to an interface
    no shutdown – Removes the shutdown command and thereby making an interface active
    end – Exit the configuration editor
    Moving through the configuration and making changes to the device settings is like navigating in a maze. Each configuration mode is like a chamber in a maze. Even if you know the map of the maze, you may still move through the maze in a disorganized way, possibly never finding a way out. Similarly, even if you know the meaning of individual commands and the modes in which they are located, the way you move through these modes when configuring a device depends mostly on you.
  4. With the help of your colleague, try to suggest how to group different commands together according to their modes so that a minimum number of moves between modes is needed.
    One of possible effective command sequences for configuring a device is:
    enable
    configure terminal
    hostname AtlantaSw

    service password-encryption
    banner login ^
    Access to this device permitted only to authorized personnel!
    ^
    enable secret V3ry5ecr3tP4ssw0rd
    line con 0
    password 5ecr3tP4ssw0rd
    login
    exit
    line vty 0 4
    password 5ecr3tP4ssw0rd
    login
    exit
    interface Vlan 1
    ip address 192.0.2.11 255.255.255.0
    no shutdown
    end
    An ineffective way of configuring would be, for example:
    enable
    configure terminal
    line con 0
    password 5ecr3tP4ssw0rd
    exit
    hostname AtlantaSw
    service password-encryption
    line vty 0 4
    password 5ecr3tP4ssw0rd
    exit
    banner login ^
    Access to this device permitted only to authorized personnel!
    ^
    line con 0
    login
    exit
    interface Vlan 1
    ip address 192.0.2.11 255.255.255.0
    exit
    line vty 0 4
    login
    exit
    enable secret V3ry5ecr3tP4ssw0rd
    interface Vlan 1
    no shutdown
    end
    (Note that while both configurations lead to the same resulting set of settings, the second configuration is slightly larger (because of repetitive entering individual modes again and again) and is very difficult to follow because the flow of commands is practically random and does not follow their logical sequence and modal commonality Answers)

Identify elements of the model that map to IT content:

  • Commands
  • Modes
  • Efficient orientation in configuration mode
  • Real-world customer relations skills