5.1.2.8 Lab – Viewing Network Device MAC Addresses Answers

5.1.2.8 Lab – Viewing Network Device MAC Addresses Answers

Lab – Viewing Network Device MAC Addresses (Answers Version – Optional Lab)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only. Optional activities are designed to enhance understanding and/or to provide additional practice.

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
S1 VLAN 1 192.168.1.2 255.255.255.0 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1

Objectives

Part 1: Configure Devices and Verify Connectivity

Part 2: Display, Describe, and Analyze Ethernet MAC Addresses

Background / Scenario

Every device on an Ethernet LAN is identified by a Layer 2 MAC address. This address is assigned by the manufacturer and stored in the firmware of the NIC. This lab will explore and analyze the components that make up a MAC address, and how you can find this information on a switch and a PC.

You will cable the equipment as shown in the topology. You will configure the switch and PC to match the addressing table. You will verify your configurations by testing for network connectivity.

After the devices have been configured and network connectivity has been verified, you will use various commands to retrieve information from the devices to answer questions about your network equipment.

Note: The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs.

Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure, ask your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 1 Switch (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 1 PC (Windows 7 or 8 with a terminal emulation program, such as Tera Term)
  • Console cable to configure the Cisco switch via the console ports
  • Ethernet cables as shown in the topology

Part 1: Configure Devices and Verify Connectivity

In this part, you will set up the network topology and configure basic settings, such as the interface IP addresses and device name. For device name and address information, refer to the Topology and Addressing Table.

Step 1: Cable the network as shown in the topology.

  1. Attach the devices shown in the topology and cable as necessary.
  2. Power on all the devices in the topology.

Step 2: Configure the IPv4 address for the PC.

  1. Configure the IPv4 address, subnet mask, and default gateway address for PC-A.
  2. From the command prompt on PC-A, ping the switch address.
    Were the pings successful? Explain.
    ____________________________________________________________________________________
    No. The switch has not been configured yet.

Step 3: Configure basic settings for the switch.

In this step, you will configure the device name and the IP address, and disable DNS lookup on the switch.

  1. Console into the switch and enter global configuration mode.
    Switch> enable
    Switch# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#
  2. Assign a hostname to the switch based on the Addressing Table.
    Switch(config)# hostname S1
  3. Disable DNS lookup.
    S1(config)# no ip domain-lookup
  4. Configure and enable the SVI interface for VLAN 1.
    S1(config)# interface vlan 1
    S1(config-if)# ip address 192.168.1.1 255.255.255.0
    S1(config-if)# no shutdown
    S1(config-if)# end
    *Mar 1 00:07:59.048: %SYS-5-CONFIG_I: Configured from console by console

Step 4: Verify network connectivity.

Ping the switch from PC-A. Were the pings successful? __________________________________________

The pings should be successful.

Part 2: Display, Describe, and Analyze Ethernet MAC Addresses

Every device on an Ethernet LAN has a MAC address that is assigned by the manufacturer and stored in the firmware of the NIC. Ethernet MAC addresses are 48-bits long. They are displayed using six sets of hexadecimal digits that are usually separated by dashes, colons, or periods. The following example shows the same MAC address using the three different notation methods:

00-05-9A-3C-78-00              00:05:9A:3C:78:00              0005.9A3C.7800

Note: MAC addresses are also called physical addresses, hardware addresses, or Ethernet hardware addresses.

You will issue commands to display the MAC addresses on a PC and a switch, and you will analyze the properties of each one.

Step 1: Analyze the MAC address for the PC-A NIC.

Before you analyze the MAC address on PC-A, look at an example from a different PC NIC. You can issue the ipconfig /all command to view the MAC address of your NIC. An example screen output is shown below. When using the ipconfig /all command, notice that MAC addresses are referred to as physical addresses. Reading the MAC address from left to right, the first six hex digits refer to the vendor (manufacturer) of this device. These first six hex digits (3 bytes) are also known as the organizationally unique identifier (OUI). This 3-byte code is assigned to the vendor by the IEEE organization. To find the manufacturer, you can use a tool like www.macvendorlookup.com or go to the IEEE web site to find the registered OUI vendor codes. The IEEE web site address for OUI information is http://standards.ieee.org/develop/regauth/oui/public.html. The last six digits are the NIC serial number assigned by the manufacturer.

  1. Using the output from the ipconfig /all command, answer the following questions.\\psf\Home\Dropbox\Screenshots\PC-A.pngWhat is the OUI portion of the MAC address for this device?________________________________________________________________________________
    5C-26-0A
    What is the serial number portion of the MAC address for this device?________________________________________________________________________________
    24-2A-60
    Using the example above, find the name of the vendor that manufactured this NIC.
    ________________________________________________________________________________
    Dell Inc.
  2. From the command prompt on PC-A, issue the ipconfig /all command and identify the OUI portion of the MAC address for the NIC of PC-A.
    ________________________________________________________________________________
    Answers will vary based on manufacturer.
    Identify the serial number portion of the MAC address for the NIC of PC-A.
    ________________________________________________________________________________
    Answers will vary based on manufacturer serial number code.
    Identify the name of the vendor that manufactured the NIC of PC-A.
    ________________________________________________________________________________
    Answers will vary based on manufacturer OUI.

Step 2: Analyze the MAC address for the S1 F0/6 interface.

You can use a variety of commands to display MAC addresses on the switch.

  1. Console into S1 and use the show interfaces vlan 1 command to find the MAC address information. A sample is shown below. Use output generated by your switch to answer the questions.S1# show interfaces vlan 1Vlan1 is up, line protocol is up  Hardware is EtherSVI, address is 001b.0c6d.8f40 (bia 001b.0c6d.8f40)  Internet address is 192.168.1.1/24  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,     reliability 255/255, txload 1/255, rxload 1/255  Encapsulation ARPA, loopback not set  Keepalive not supported  ARP type: ARPA, ARP Timeout 04:00:00  Last input never, output 00:14:51, output hang never  Last clearing of “show interface” counters never  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  Queueing strategy: fifo  Output queue: 0/40 (size/max)  5 minute input rate 0 bits/sec, 0 packets/sec  5 minute output rate 0 bits/sec, 0 packets/sec     0 packets input, 0 bytes, 0 no buffer     Received 0 broadcasts (0 IP multicasts)     0 runts, 0 giants, 0 throttles     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored     34 packets output, 11119 bytes, 0 underruns

         0 output errors, 2 interface resets

         0 unknown protocol drops

         0 output buffer failures, 0 output buffers swapped out

    What is the MAC address for VLAN 1 on S1?____________________________________________________________________________________
    Answers will vary based on the switch the student is using. Using the output from above, the answer would be 001b.0c6d.8f40.
    What is the MAC serial number for VLAN 1?____________________________________________________________________________________
    Answers will vary based on the switch the student is using. Using the output from above, the answer would be 6d-8f-40.

    What is the OUI for VLAN 1?____________________________________________________________________________________
    Answers will vary based on the switch the student is using. Using the output from above, the answer would be 00-1b-0c.

    Based on this OUI, what is the name of the vendor?____________________________________________________________________________________
    Cisco Systems

    What does bia stand for?____________________________________________________________________________________
    Burned in address.

    Why does the output show the same MAC address twice?____________________________________________________________________________________
    The MAC address can be changed via a software command. The actual address (bia) will still be there. It is shown in the parenthesis.

  2. Another way to display the MAC address on the switch is to use the show arp command. Use the show arp command to display MAC address information. This command maps the Layer 2 address to its corresponding Layer 3 address. A sample is shown below. Use output generated by your switch to answer the questions.S1# show arpProtocol  Address          Age (min)  Hardware Addr   Type   InterfaceInternet  192.168.1.1             –   001b.0c6d.8f40  ARPA   Vlan1Internet  192.168.1.3             0   5c26.0a24.2a60  ARPA   Vlan1What Layer 2 addresses are displayed on S1?____________________________________________________________________________________
    S1 VLAN 1 and PC-A MAC addresses. If the student also records the MAC addresses, their answers will vary.What Layer 3 addresses are displayed on S1?____________________________________________________________________________________
    S1 and PC-A IP addresses

Step 3: View the MAC addresses on the switch.

Issue the show mac address-table command on S1. A sample is shown below. Use output generated by your switch to answer the questions.

Answers Note: The show mac address-table command can vary based on the model switch you are using. For example, the syntax on some switches is show mac-address-table.

S1# show mac address-table

          Mac Address Table

——————————————-

Vlan    Mac Address       Type        Ports

—-    ———–       ——–    —–

 All    0100.0ccc.cccc    STATIC      CPU

 All    0100.0ccc.cccd    STATIC      CPU

 All    0180.c200.0000    STATIC      CPU

 All    0180.c200.0001    STATIC      CPU

 All    0180.c200.0002    STATIC      CPU

 All    0180.c200.0003    STATIC      CPU

 All    0180.c200.0004    STATIC      CPU

 All    0180.c200.0005    STATIC      CPU

 All    0180.c200.0006    STATIC      CPU

 All    0180.c200.0007    STATIC      CPU

 All    0180.c200.0008    STATIC      CPU

 All    0180.c200.0009    STATIC      CPU

 All    0180.c200.000a    STATIC      CPU

 All    0180.c200.000b    STATIC      CPU

 All    0180.c200.000c    STATIC      CPU

 All    0180.c200.000d    STATIC      CPU

 All    0180.c200.000e    STATIC      CPU

 All    0180.c200.000f    STATIC      CPU

 All    0180.c200.0010    STATIC      CPU

 All    ffff.ffff.ffff    STATIC      CPU

   1    5c26.0a24.2a60    DYNAMIC     Fa0/6

Total Mac Addresses for this criterion: 21

Did the switch display the MAC address of PC-A? If you answered yes, what port was it on?

____________________________________________________________________________________

Yes. Port should be F0/6. Answers will vary for the MAC address. In the example above, the MAC address would be 5c26.0a24.2a60.

Reflection

  1. Can you have broadcasts at the Layer 2 level? If so, what would the MAC address be?_______________________________________________________________________________________
    You can have broadcasts at Layer 2. ARP will use broadcasts to find MAC address information. The broadcast address is FF.FF.FF.FF.FF.FF.
  2. Why would you need to know the MAC address of a device?_______________________________________________________________________________________
    There could be a variety of reasons. In a large network, it may be easier to pinpoint location and identity of a device by its MAC address instead of its IP address. The MAC OUI will list the manufacturer, which may help narrow down the search. Security measures can be applied at Layer 2, so knowledge of allowable MAC addresses is needed.

Device Config

Switch S1

S1# show run

Building configuration…

Current configuration : 1335 bytes

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname S1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

system mtu routing 1500

!

no ip domain-lookup

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

 ip address 192.168.1.1 255.255.255.0

!

ip http server

ip http secure-server

logging esm config

!

line con 0

line vty 5 15

!

end