6.3.3.6 Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing

6.3.3.6 Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing

From year to year, Cisco has updated many versions with difference questions. The latest version is version 6.0 in 2018. What is your version? It depends on your instructor creating your class. We recommend you to go thought all version if you are not clear. While you take online test with netacad.com, You may get random questions from all version. Each version have 1 to 10 different questions or more. After you review all questions, You should practice with our online test system by go to "Online Test" link below.

Version 5.02Version 5.03Version 6.0Online Assessment
Chapter 6 ExamChapter 6 ExamChapter 6 ExamOnline Test
Next Chapter
Chapter 7 ExamChapter 7 ExamChapter 7 ExamOnline Test
Lab Activities
 6.1.1.5 Packet Tracer – Who Hears the Broadcast
 6.1.2.7 Packet Tracer – Investigating a VLAN Implementation
 6.2.1.7 Packet Tracer – Configuring VLANs
 6.2.2.4 Packet Tracer – Configuring Trunks
 6.2.3.7 Packet Tracer – Troubleshooting a VLAN Implementation – Scenario 1
 6.2.3.8 Packet Tracer – Troubleshooting a VLAN Implementation – Scenario 2
 6.3.3.6 Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing
 6.3.3.8 Packet Tracer – Inter-VLAN Routing Challenge
 6.4.1.2 Packet Tracer – Skills Integration Challenge

Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing (Answer Version)

Answer Note: Red font color or Gray highlights indicate text that appears in the Answer copy only.

Topology

6.3.3.6 Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing

6.3.3.6 Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing

Addressing Table

DeviceInterfaceIPv4 AddressSubnet MaskDefault Gateway
R1G0/0.10172.17.10.1255.255.255.0N/A
G0/0.30172.17.30.1255.255.255.0N/A
PC1NIC172.17.10.10255.255.255.0172.17.10.1
PC2NIC172.17.30.10255.255.255.0172.17.30.1

Objectives

Part 1: Test Connectivity without Inter-VLAN Routing

Part 2: Add VLANs to a Switch

Part 3: Configure Subinterfaces

Part 4: Test Connectivity with Inter-VLAN Routing

Scenario

In this activity, you will check for connectivity prior to implementing inter-VLAN routing. You will then configure VLANs and inter-VLAN routing. Finally, you will enable trunking and verify connectivity between VLANs.

Part 1: Test Connectivity Without Inter-VLAN Routing

Step 1: Ping between PC1 and PC3.

Wait for switch convergence or click Fast Forward Time a few times. When the link lights are green for PC1 and PC3, ping between PC1 and PC3. Because the two PCs are on separate networks and R1 is not configured, the ping fails.

Step 2: Switch to Simulation mode to monitor pings.

  1. Switch to Simulation mode by clicking the Simulation tab or pressing Shift+S.
  2. Click Capture/Forward to see the steps the ping takes between PC1 and PC3. Notice how the ping never leaves PC1. What process failed and why? The ARP process failed because the ARP request never reached PC3. PC1 and PC3 are not on the same network, so S1 doesn’t forward PC1’s ARP request (a broadcast packet) to VLAN30. PC1 never gets the MAC address for PC3. Without a MAC address, PC1 cannot create an ICMP echo request.

Part 2: Add VLANs to a Switch

Step 1: Create VLANs on S1.

Return to Realtime mode and create VLAN 10 and VLAN 30 on S1.

S1(config)# vlan 10
S1(config-vlan)# vlan 30

Step 2: Assign VLANs to ports.

  1. Configure interface F0/6 and F0/11 as access ports and assign VLANs.
    • Assign PC1 to VLAN 10.
    • Assign PC3 to VLAN 30.
      • S1(config-vlan)# int fa0/11
      • S1(config-if)# switchport mode access
      • S1(config-if)# switchport access vlan 10
      • S1(config-if)# int fa0/6
      • S1(config-if)# switchport mode access
      • S1(config-if)# switchport access vlan 30
  2. Issue the show vlan brief command to verify VLAN configuration.

S1# show vlan brief

VLAN Name                                       Status      Ports

—- ——————————–     ———    ——————————-

1    default                                           active        Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                                                                Fa0/5, Fa0/7, Fa0/8, Fa0/9

                                                                                Fa0/10, Fa0/12, Fa0/13, Fa0/14

                                                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18

                                                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22

                                                                                Fa0/23, Fa0/24, Gig0/1, Gig0/2

10   VLAN0010                                active         Fa0/11

30   VLAN0030                               active         Fa0/6

1002 fddi-default                            active

1003 token-ring-default                active

1004 fddinet-default                      active

1005 trnet-default                           active

Step 3: Test connectivity between PC1 and PC3.

From PC1, ping PC3. The pings should still fail. Why were the pings unsuccessful? Each VLAN is a separate network and requires a router or a layer 3 switch to provide communication between them.

Part 3: Configure Subinterfaces

Step 1: Configure subinterfaces on R1 using the 802.1Q encapsulation.

  1. Create the subinterface G0/0.10.
    • Set the encapsulation type to 802.1Q and assign VLAN 10 to the subinterface.
    • Refer to the Address Table and assign the correct IP address to the subinterface.
  2. Repeat for the G0/0.30 subinterface.
R1(config)# int g0/0.10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# ip address 172.17.10.1 255.255.255.0
R1(config-subif)# int g0/0.30
R1(config-subif)# encapsulation dot1Q 30
R1(config-subif)# ip address 172.17.30.1 255.255.255.0

Step 2: Verify Configuration.

  1. Use the show ip interface brief command to verify subinterface configuration. Both subinterfaces are down. Subinterfaces are virtual interfaces that are associated with a physical interface. Therefore, in order to enable subinterfaces, you must enable the physical interface that they are associated with.
  2. Enable the G0/0 interface. Verify that the subinterfaces are now active.

Part 4 : Test Connectivity with Inter-VLAN Routing

Step 1: Ping between PC1 and PC3.

From PC1, ping PC3. The pings should still fail.

Step 2: Enable trunking.

  1. On S1, issue the show vlan command. What VLAN is G0/1 assigned to? VLAN 1
  2. Because the router was configured with multiple subinterfaces assigned to different VLANs, the switch port connecting to the router must be configured as a trunk. Enable trunking on interface G0/1.
    • S1(config-if)# int g0/1
    • S1(config-if)# switchport mode trunk
  3. How can you determine that the interface is a trunk port using the show vlan command? The interface is no longer listed under VLAN 1.
  4. Issue the show interface trunk command to verify the interface is configured as a trunk.

Step 3: Switch to Simulation mode to monitor pings.

  1. Switch to Simulation mode by clicking the Simulation tab or pressing Shift+S.
  2. Click Capture/Forward to see the steps the ping takes between PC1 and PC3.
  3. You should see ARP requests and replies between S1 and R1. Then ARP requests and replies between R1 and S3. Then PC1 can encapsulate an ICMP echo request with the proper data-link layer information and R1 will route the request to PC3.

Note: After the ARP process finishes, you may need to click Reset Simulation to see the ICMP process complete.

From year to year, Cisco has updated many versions with difference questions. The latest version is version 6.0 in 2018. What is your version? It depends on your instructor creating your class. We recommend you to go thought all version if you are not clear. While you take online test with netacad.com, You may get random questions from all version. Each version have 1 to 10 different questions or more. After you review all questions, You should practice with our online test system by go to "Online Test" link below.

Version 5.02Version 5.03Version 6.0Online Assessment
Chapter 6 ExamChapter 6 ExamChapter 6 ExamOnline Test
Next Chapter
Chapter 7 ExamChapter 7 ExamChapter 7 ExamOnline Test
Lab Activities
 6.1.1.5 Packet Tracer – Who Hears the Broadcast
 6.1.2.7 Packet Tracer – Investigating a VLAN Implementation
 6.2.1.7 Packet Tracer – Configuring VLANs
 6.2.2.4 Packet Tracer – Configuring Trunks
 6.2.3.7 Packet Tracer – Troubleshooting a VLAN Implementation – Scenario 1
 6.2.3.8 Packet Tracer – Troubleshooting a VLAN Implementation – Scenario 2
 6.3.3.6 Packet Tracer – Configuring Router-on-a-Stick Inter-VLAN Routing
 6.3.3.8 Packet Tracer – Inter-VLAN Routing Challenge
 6.4.1.2 Packet Tracer – Skills Integration Challenge

Suggested Scoring Rubric

Packet Tracer scores 60 points. The four questions are worth 10 points each.