8.1.4.8 Lab – Designing and Implementing a Subnetted IPv4 Addressing Scheme Answers

8.1.4.8 Lab – Designing and Implementing a Subnetted IPv4 Addressing Scheme Answers

Lab – Designing and Implementing a Subnetted IPv4 Addressing Scheme (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 G0/0 N/A
G0/1 N/A
Lo0 N/A
Lo1 N/A
S1 VLAN 1 N/A N/A N/A
PC-A NIC
PC-B NIC

Objectives

Part 1: Design a Network Subnetting Scheme

Part 2: Configure the Devices

Part 3: Test and Troubleshoot the Network

Background / Scenario

In this lab, starting from a single network address and network mask, you will subnet the network into multiple subnets. The subnet scheme should be based on the number of host computers required in each subnet, as well as other network considerations, like future network host expansion.

After you have created a subnetting scheme and completed the network diagram by filling in the host and interface IP addresses, you will configure the host PCs and router interfaces, including loopback interfaces. The loopback interfaces are created to simulate additional LANs attached to router R1.

After the network devices and host PCs have been configured, you will use the ping command to test for network connectivity.

This lab provides minimal assistance with the actual commands necessary to configure the router. However, the required commands are provided in Appendix A. Test your knowledge by trying to configure the devices without referring to the appendix.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at this end of the lab for the correct interface identifiers.

Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 1 Router (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 1 Switch (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 2 PCs (Windows 7 or 8 with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Note: The Gigabit Ethernet interfaces on Cisco 1941 routers are autosensing. An Ethernet straight-through cable may be used between the router and PC-B. If using another Cisco router model, it may be necessary to use an Ethernet crossover cable.

Part 1: Design a Network Subnetting Scheme

Step 1: Create a subnetting scheme that meets the required number of subnets and required number of host addresses.

In this scenario, you are a network administrator for a small subdivision within a larger company. You must create multiple subnets out of the 192.168.0.0/24 network address space to meet the following requirements:

  • The first subnet is the employee network. You need a minimum of 25 host IP addresses.
  • The second subnet is the administration network. You need a minimum of 10 IP addresses.
  • The third and fourth subnets are reserved as virtual networks on virtual router interfaces, loopback 0 and loopback 1. These virtual router interfaces simulate LANs attached to R1.
  • You also need two additional unused subnets for future network expansion.

Note: Variable length subnet masks will not be used. All of the device subnet masks will be the same length.

Answer the following questions to help create a subnetting scheme that meets the stated network requirements:

  1. How many host addresses are needed in the largest required subnet? _____________________ 25
  2. What is the minimum number of subnets required? _________________________________
    The requirements stated above specify two company networks plus two loopback virtual networks, plus two additional networks for future expansion. So, the answer is a minimum of six networks.
  3. The network that you are tasked to subnet is 192.168.0.0/24. What is the /24 subnet mask in binary?________________________________________________________________________________
    1111111.11111111.11111111.00000000
  4. The subnet mask is made up of two portions, the network portion, and the host portion. This is represented in the binary by the ones and the zeros in the subnet mask.
    In the network mask, what do the ones represent? ________________________________________
    The ones represent the network portion.
    In the network mask, what do the zeros represent? _______________________________________
    The zeroes represent the host portion.
  5. To subnet a network, bits from the host portion of the original network mask are changed into subnet bits. The number of subnet bits defines the number of subnets. Given each of the possible subnet masks depicted in the following binary format, how many subnets and how many hosts are created in each example?
    Hint: Remember that the number of host bits (to the power of 2) defines the number of hosts per subnet (minus 2), and the number of subnet bits (to the power of two) defines the number of subnets. The subnet bits (depicted in bold type face) are the bits that have been borrowed beyond the original network mask of /24. The /24 is the slash prefix notation and corresponds to a dotted decimal mask of 255.255.255.0.
    (/25) 11111111.11111111.11111111.10000000
    Dotted decimal subnet mask equivalent: ________________________________
    255.255.255.128
    Number of subnets? ________________, Number of hosts? ________________
    Two subnets (21) and 128 hosts (27) – 2 = 126 hosts per subnet
    (/26) 11111111.11111111.11111111.11000000
    Dotted decimal subnet mask equivalent: ________________________________
    255.255.255.192
    Number of subnets? ________________, Number of hosts? ________________
    Four subnets (22) and 64 hosts (26) – 2 = 62 hosts per subnet
    (/27) 11111111.11111111.11111111.11100000
    Dotted decimal subnet mask equivalent: ________________________________
    255.255.255.224
    Number of subnets? ________________ Number of hosts? ________________
    Eight subnets (23) and 32 hosts (25) – 2 = 30 hosts per subnet
    (/28) 11111111.11111111.11111111.11110000
    Dotted decimal subnet mask equivalent: ________________________________
    255.255.255.240
    Number of subnets? ________________ Number of hosts? _________________
    Sixteen subnets (24) and 16 hosts (24) – 2 = 14 hosts per subnet
    (/29) 11111111.11111111.11111111.11111000
    Dotted decimal subnet mask equivalent: ________________________________
    255.255.255.248
    Number of subnets? ________________ Number of hosts? _________________
    Thirty two subnets (25) and 8 hosts (23) – 2 = 6 hosts per subnet
    (/30) 11111111.11111111.11111111.11111100
    Dotted decimal subnet mask equivalent: ________________________________
    255.255.255.252
    Number of subnets? ________________ Number of hosts? _________________
    Sixty four subnets (26) and 4 hosts (22) – 2 = 2 hosts per subnet
  6. Considering your answers, which subnet masks meet the required number of minimum host addresses?________________________________________________________________________________
    /25, /26, /27
  7. Considering your answers, which subnet masks meets the minimum number of subnets required?________________________________________________________________________________
    /27, /28, /29, /30 will give the required number of subnets.
  8. Considering your answers, which subnet mask meets both the required minimum number of hosts and the minimum number of subnets required?________________________________________________________________________________
    /27 will give you eight subnets, which is greater than the minimum of five required, and 30 hosts per subnet, which is greater than the 25 hosts required for the first subnet.
  9. When you have determined which subnet mask meets all of the stated network requirements, you will derive each of the subnets starting from the original network address. List the subnets from first to last below. Remember that the first subnet is 192.168.0.0 with the newly acquired subnet mask.
    Subnet Address                 / Prefix    Subnet Mask (dotted decimal)
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    ___________________ / ____    __________________________
    192.168.0.0, 192.168.0.32, 192.168.0.64, 192.168.0.96, 192.168.0.128, 192.168.0.160, 192.168.0.192, 192.168.0.224 All prefix is /27. All subnet mask is (dotted decimal) 255.255.255.224.

Step 2: Complete the diagram showing where the host IP addresses will be applied.

On the following lines provided, fill in the IP addresses and subnets masks in slash prefix notation. On the router, use the first usable address in each subnet for each of the interfaces, Gigabit Ethernet 0/0, Gigabit Ethernet 0/1, loopback 0, and loopback 1. Fill in an IP address for both PC-A and PC-B. Also enter this information into the Addressing Table on Page 1.

The addresses of the router Gigabit Ethernet 0/0, Gigabit Ethernet 0/1, loopback 0 and loopback 1 interfaces would be: 192.168.0.1/27, 192.168.0.33/27, 192.168.0.65/27, 192.168.0.97/27. If the Gigabit 0/0 interface is the first subnet then PC-B’s IP address would be a number between 192.168.0.2 and 192.168.0.30. If the Gigabit 0/1 interface is the second subnet, then PC-A’s IP address would be a number between 192.168.0.34 and 192.168.0.62.

Part 2: Configure the Devices

In Part 2, set up the network topology and configure basic settings on the PCs and router, such as the router Gigabit Ethernet interface IP addresses, and the PC’s IP addresses, subnet masks, and default gateways. Refer to the Addressing Table for device names and address information.

Note: Appendix A provides configuration details for the steps in Part 2. You should attempt to complete Part 2 prior to reviewing Appendix A.

Step 1: Configure the router.

  1. Enter into privileged EXEC mode and then global config mode.
  2. Assign the R1 as the hostname for the router.
  3. Configure both the G0/0 and G0/1 interfaces with IP addresses and subnet masks, and then enable them.
  4. Loopback interfaces are created to simulate additional LANs on R1 router. Configure the loopback interfaces with IP addresses and subnet masks. After they are created, loopback interfaces are enabled, by default. (To create the loopback addresses, enter the command interface loopback 0 at the global config mode)
    Note: You can create additional loopbacks for testing with different addressing schemes, if desired.
  5. Save the running configuration to the startup configuration file.

Step 2: Configure the PC interfaces.

  1. Configure the IP address, subnet mask, and default gateway settings on PC-A.
  2. Configure the IP address, subnet mask, and default gateway settings on PC-B.

Part 3: Test and Troubleshoot the Network

In Part 3, you will use the ping command to test network connectivity.

  1. Test to see if PC-A can communicate with its default gateway. From PC-A, open a command prompt and ping the IP address of the router Gigabit Ethernet 0/1 interface. Do you get a reply? _________________
    If the PC and router interface have been configured correctly then the ping should be successful. If not, check items d and e below.
  2. Test to see if PC-B can communicate with its default gateway. From PC-B, open a command prompt and ping the IP address of the router Gigabit Ethernet 0/0 interface. Do you get a reply? ________________
    If the PC and router interface have been configured correctly then the ping should be successful. If not, check items d and e below.
  3. Test to see if PC-A can communicate with PC-B. From PC-A, open a command prompt and ping the IP address of PC-B. Do you get a reply? _________________
    If both PCs and the router Gigabit Ethernet interfaces have been configured correctly, then the pings should be successful. If not, check items d and e below.
  4. If you answered “no” to any of the preceding questions, then you should go back and check all of your IP address and subnet mask configurations, and ensure that the default gateways have been correctly configured on PC-A and PC-B.
  5. If you verify that all of the settings are correct, and you can still not ping successfully, then there are a few additional factors that can block ICMP pings. On PC-A and PC-B within Windows, make sure that the Windows Firewall is turned off for the Work, Home, and Public networks.
  6. Experiment by purposely misconfiguring the gateway address on PC-A to 10.0.0.1. What happens when you try and ping from PC-B to PC-A? Do you receive a reply?________________________________________________________________________________________________________________________________________________________________________
    With deliberate misconfigurations, the answer should be no.

Reflection

  1. Subnetting one larger network into multiple smaller subnetworks allows for greater flexibility and security in network design. However, what do you think some of the drawbacks are when the subnets are limited to being the same size?______________________________________________________________________________________________________________________________________________________________________________
    Answers will vary. Students may suggest that, because some subnetworks require many ip addresses and others require only a few, having all of the subnets the same size is not the most efficient way to divide the subnets.
  2. Why do you think the gateway/router IP address is usually the first usable IP address in the network?______________________________________________________________________________________________________________________________________________________________________________
    Answers will vary. It may be suggested that the router or gateway is like a door to the network and therefore it is logical that its address is at the beginning of the network. It is purely a convention however, and therefore the router does not have to have the first or last address in the network.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Appendix A: Configuration Details for Steps in Part 2

Step 1: Configure the router.

  1. Console into the router and enable privileged EXEC mode.
    Router> enable
    Router#
  2. Enter into configuration mode.
    Router# conf t
    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#
  3. Assign a device name to the router.
    Router(config)# hostname R1
    R1(config)#
  4. Configure both the G0/0 and G0/1 interfaces with IP addresses and subnet masks, and enable them.
    R1(config)# interface g0/0
    R1(config-if)# ip address <ip address> <subnet mask>
    R1(config-if)# no shutdown
    R1(config-if)# interface g0/1
    R1(config-if)# ip address <ip address> <subnet mask>
    R1(config-if)# no shutdown
  5. Loopback interfaces are created to simulate additional LANs off of router R1. Configure the loopback interfaces with IP addresses and subnet masks. When they are created, loopback interfaces are enabled, by default.
    R1(config)# interface loopback 0
    R1(config-if)# ip address <ip address> <subnet mask>
    R1(config-if)# interface loopback 1
    R1(config-if)# ip address <ip address> <subnet mask>
    R1(config-if)# end
  6. Save the running configuration to the startup configuration file.
    R1# copy running-config startup-config

Step 2: Configure the PC interfaces.

  1. Configure the IP address, subnet mask, and default gateway settings on PC-A.ch08-labd2
  2. Configure the IP address, subnet mask, and default gateway settings on PC-B.ch08-labd1

Device Configs

Router R1

R1#show run

Building configuration…

Current configuration : 1518 bytes

!

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

!

no ipv6 cef

ip auth-proxy max-login-attempts 5

ip admission max-login-attempts 5

!

!

!

!

!

ip cef

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

!

!

!

redundancy

!

!

!

!

interface Loopback0

ip address 192.168.0.65 255.255.255.224

!

interface Loopback1

ip address 192.168.0.97 255.255.255.224

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.0.1 255.255.255.224

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.0.33 255.255.255.224

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

!

end